0 comments

i have a 2007 Kenworth t2000 that i bought 3 years ago and have been breaking s cam tubes on all four back wheels numerous times the left front three times alone and on three occasions it will break the spider gear and wheel seal i have purchased 7 s cam tubes in a three year time frame so i get on line and look it up sure enough there is a recall on the ag400 8 bag setup and they have a fix for it so i call pacar in Washington state and they tell me to get InTouch with my local dealer to get the truck fixed remember that when the s cam tube breaks that break is no longer working and i had two at one time break on me so ya its a big deal especially on a large truck with up to 80,000 lbs.of weight the dealer in Wichita KS tells me he will look into it and gets back to me a week later and the tell me it will cost me 2200 dollars to repair and a few days down time but i thought it was a recall ?

he tells me that my truck did not leave the factory with super singles on it and that they puts more strain on the s came tube.....?

when the trucking company that bought the truck new they had the mhc of Tulsa Kenworth dealership put them on the truck.Wichita kw tells me to go to them Tulsa basically said its on me if i want this fix so my breaks work I'm going to have to pay for it recall or not.....i guess they don't think that their family drives around me to much so they don't worry about my stopping before killing anyone that stops to hard in front of me i will fix it myself and Volvo looks like they will be my next truck

Reason of review: Bad quality.

Monetary Loss: $4000.

Preferred solution: fix my truck so its safe around people.

Do You Have Something To Say ?

Write a review

Comments

Terms of Service
Post Comment
Cancel

You May Also Like